Bug Reports 1 2 »
Users browsing this thread: 1 Guest(s)

Please post your bug reports here, and I'll fix as many as possible.

Here are a few:
Some farming drop around level 45 farming causes a script error that renders the map inaccessible until drops are cleared.
Plate armor causes a script error and can be worn with other armor.

Not really a bug, but you can't pick up dropped storage items in the dungeon. Lost a fishing net and a treasure chest because I tried to manage my inventory.

On Mac, at least for me, any attempts to use the new character or login options results in a box appearing with the error message:

​Director Player Error
Xtra not found


Script Error. Continue?

Pressing yes just makes the box pop up again, and pressing no crashes the game. I've tried the standard and mirror downloads, as well as downloading the windows version and running it with wine. They all give the same result.

This is my first ever forum post in my whole life so I'm sorry if this is super amatuer. I'm not quite tech savvy with Macs, but I can't even open the application. The app symbol has a crossed circle and gives me an error saying “First Star Online 3” needs to be updated. The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information. My assumption is that I most likely messed something up because other people must have been able to play on Mac. I've downloaded the original link and the mirror link and both haven't got it to work. My specs are as such below.

MacBook Pro (Retina, 13-inch, Late 2013)
Processor 2.4 GHz Dual-Core Intel Core i5
Memory 4 GB 1600 MHz DDR3
Startup Disk Macintosh HD
Graphics Intel Iris 1536 MB

I hope it's something on my end because I'm pretty interested in this game. Hopefully a solution can arise. Thank you for your patience as well.

im new and still low level.
but i seem to have found several bugs which affect greatly on player's progression

[broken quest NPC]​
Paul (Town Ji, in front of weapon shop)
Errus (outskirts of Sert, on pier)
*both of them don't show even pop-up menu (Buy, Sell, Job) when clicked

[reward disappears]​
Cruk (Lumberjack of Ji, 5 repair hammers disappear in no time or after re-login)
Merl (weapon&armor shop of Whisper, again, 18 repair hammers disappear)
Cran (craft shop of Whisper, small backpack disappears)
(This post was last modified: 31-05-2022, 03:46 PM by Duhlocke.)

found unseen obstacle/mob which i can attack but not kill nor trespassing.
(seems to be temporal glitch. it's gone after switching area couple of times.)

its just outside of Ji.
pls check screenshot.
(This post was last modified: 07-06-2022, 12:07 PM by Duhlocke.)

Attached Files    


has been known to me, but confirmed its reproducible.

it happens to the char who returned from dungeon

all player's levels are showed as 1 in "who's online ?" window

(This post was last modified: 08-06-2022, 11:22 AM by Duhlocke.)


weapon shop of Ji turned into arena


found 2 bugs in easy dungeon

1. yesterday, i couldn't buy from dungeon shop NPC. (clicking 'OK' didn't respond)
2. today, this happened. after all mobs in the room wiped out, i couldn't proceed to door corridor which was the only way out.
(This post was last modified: 16-06-2022, 03:47 AM by Duhlocke.)


same dungeon bug still persists.
it seems the very way out where player came from is glitched.
its actually not opened (against the look) after all mobs were wiped out.

Bug Reports 1 2 »
Users browsing this thread: 1 Guest(s)